The Unscrambler® Functional FAQs
NEW FEATURES 
FAQ What Is New in The Unscrambler® 9.1?
 
  3D Editor
Swapping of 3D tables in 12 Layouts
  Analysis
3-way PLS Regression
Automatic Pretreatments in prediction and classification
  User-friendliness
New PC Navigation Toolbar
  New Import Features
F3D (Hitachi)
Indico (Analytical Spectral Devices)
Save 2D data files in Unscrambler 7.8 Data format

[ BACK | TOP ]

 
FAQ What Is New in The Unscrambler® 9.0?
 
  Upgrading from Version 8.0.5
  Upgrading from Version 8.0
  Upgrading from Version 7.8
  Upgrading from Version 7.6
  Upgrading from Version 7.5
  Upgrading from Version 7.01

 

[ BACK | TOP ]


 If You Are Upgrading from Version 8.0.5
These are the first features that were implemented after version 8.0.5.

Analysis

  1. New analysis method:
    Three-Way PLS regression. Open a 3D data table, then use menu "Task-Regression".

    The following key features can be named:
    Two validation methods available (Cross-Validation and Test Set), Scaling and Centering options, over 50 pre-defined plots to view the model results, over 60 importable result matrices.

  2. The following data pretreatments and their combinations are available as automatic pretreatments in Classification and Prediction:
    Smoothing, Normalize, Spectroscopic, MSC, Noise, Derivatives, Baselines. Combinations of these pretreatments are also supported in auto-pretreatments.

3D Editor

  1. Toggle between the 12 possible layouts of 3D tables with submenus in the Modify menu or using Ctrl+3
  2. Create Primary Variable and Secondary Variable sets for use in 3-Way analysis. Use menu Modify-Edit Set on an active 3D table.


User-friendliness

  1. Optimized PC-Navigation toolbar. Freely switch PC numbers by a simple click on the Next horizontal PC, Previous horizontal PC, Next vertical PC, Previous vertical PC and Suggested PC buttons, or use the corresponding arrow keys on your keyboard. The PC-Navigation tool is available on all PCA, PCR, PLS-R and Prediction result plots.
  2. A shortcut key Ctrl+R was created for File-Import-Unscrambler Results

Compatibility with other software

  1. Importation of 3D tables from Matlab supported. Use menu File-Import 3D-Matlab
  2. Importation of *.F3D file format from Hitachi supported. Use menu File-Import 3D-F3D
  3. Importation of files from Analytical Spectral Devices software supported (file extensions: *.001 and *.asd). Use menu File-Import-Indico

Visualisation

  1. Passified variables are displayed in a different color from non-passified variables on Bi-Plots, so that they are easily identified.
  2. Plot header and axes denomination are shown on 2D Scatter plots, 3D Scatter plots, histogram plots, Normal probability plots and matrix plots of raw data.

Plus several bug fixes and minor improvements

[ BACK | TOP ]


 If You Are Upgrading from Version 8.0
These are the first features that were implemented after version 8.0. Also read chapter "If You Are Upgrading from version 8.0.5". for newer features.

Analysis

  1. In SIMCA-classification results, significance level "None" was introduced in Sivs Hi and Si/S0 vs Hi plots. This option allows to display these plots with no
    significance limits, as was implemented for Coomans'plot in version 8.0
  2. The chosen variable weights are more accurately indicated than in previous versions in the PCA and Regression dialogs
  3. Weighting is free for each model term, except with the Passify option which automatically passifies all interactions and squares of passified main effects.
    The user can change this default by using the "Weights..." button in the PCA and Regression dialogs.

Visualisation

  1. Passified variables are displayed in a different color from non-passified variables on Loadings and Correlation Loadings plots so that they are easily
    identified.
  2. When computing a PCR or PLS-R model with Uncertainty Test, the significant X-variables are marked by default when opening the results Viewer

Compatibility with other software

  1. Importation of file formats *.asc, *.scn and *.autoscan from Guided Wave is now supported (CLASS-PA and SpectrOn software)
  2. Importing very large ASCII data files is subsequently faster than in previous versions

Plus several bug fixes and minor improvements

[ BACK | TOP ]

If You Are Upgrading from Version 7.8
These are the first features that were implemented after version 7.8.

User-friendliness

  1. Undo-Redo buttons are available for most Editor functions.
  2. A Guided Expression dialog makes the Compute function simpler and more intuitive to use.
  3. Sort Variable Sets and Sort Sample Sets are now available even in the presence of overlapping sets.
  4. Switch PC numbers by a simple click on the "Next PC" and "Previous PC" buttons in most plots of the PCA, PCR and PLS regression results.
  5. New function in the marking toolbar: Reverse marking
  6. Possibility to save plots in five image formats (Bitmap, Jpeg, Gif, Portable network graphics and TIFF)
  7. An « Undo Adjust » button allows you to regret forcing a simplex onto your mixture design
  8. New User Guide documentation in html format - click and read!

Visualization
  1. Sample grouping options let you choose how many groups to use, which sample ID should be displayed on the plot and how many decimals/characters to be displayed.
  2. Possibility to perform Sample Grouping with symbols instead of colours. It allows to visualise groups also when printing plots in black & white.
  3. The Loadings plot replaces the Loading Weights plot in Regression Overview results, thus allowing easy access to the Correlation loadings plot.
  4. Select « None » as significance limits in Cooman's plot (classification)

Analysis
  1. Improved Passify weights
  2. Improved Uncertainty test (Jack-knife variance estimates)
  3. The raw regression coefficients are available through the Plot menu. In addition, B0 or B0W values are indicated on the regression coefficients plots.
  4. Skewness is included in the View-Statistics tables.

Traceability
  1. Data and model files information indicate the software version that was used to create the file.
  2. The Empty button in File-Properties-Log can be disabled in the administrator system setup options, preventing the user from deleting the log of performed operations.
[ BACK | TOP ]


 If You Are Upgrading from Version 7.6
These are the first features that were implemented after version 7.6. Also read chapter If You Are Upgrading from Version 7.8 for newer features.
  1. Easy and automated import of ASCII files:
    You can launch The Unscrambler® from an external application and automatically read the contents of ASCII files into a new Unscrambler data table.
  2. Enhanced Import features:
    Space is no longer a default item delimiter when importing from ASCII files. Instead it is available as an option among other delimiters.
  3. Enhanced Editor functions:
    1. You may now Reverse Sample Order or Reverse Variable Order in your data table. It is also possible to Sort by Sample Sets or by Variable Sets.
    2. It is now possible to create new Sample Sets from a Category Variable.
    3. Sample and Variable Sets now support any Set size, even if the range is non-continuous.
  4. Improved Recalculate options:
    1. You may now Passify X- or Y-variables when recalculating your PCA, PCR or PLS model. The variables are kept in the analysis but are weighted close to zero so as not to influence the model.
    2. A bug fix allows you to keep out Y-variables by using "Recalculate Without Marked".
  5. Improved D-optimal design interface:
    1. More user-friendly definition of multi-linear constraints.
    2. Better information about the condition number of your design.
  6. New function User Defined Analysis:
    You may now add your own analysis routines for 3D data. This works with DLLs, in the same way as User Defined Transformations.

[ BACK | TOP ]


If You Are Upgrading from Version 7.5
These are the first features that were implemented after version 7.5. Also read chapters If You Are Upgrading from Version 7.6 and If You Are Upgrading from Version 7.8 for newer features.

  1. New data structure: It is now possible to import or convert data into a 3-D structure.
  2. Work with category variables: Easier importation of category variables.
  3. Customizable model size: Save your models in the appropriate size: Full, Compact or Minimum.
  4. Loadings: Correlation Loadings are now implemented and help you interpret variable correlations in Loading plots.
  5. Export to and Import from Matlab: You can directly export data to Matlab, or import data from Matlab including sample and variable names.
  6. New import format: MVACDF.

[ BACK | TOP ]


If You Are Upgrading from Version 7.01

These are the first features that were implemented after version 7.01. Also read chapters If You Are Upgrading from Version 7.5, If You Are Upgrading from Version 7.6 and If You Are Upgrading from Version 7.8 for newer features.
  1. Martens Uncertainty test:
    New and unique method based on "Jack-knifing", for safer interpretation with significance testing. The new method developed by Dr. Harald Martens shows you which variables are significant or not, the uncertainty estimates for the variables and the model robustness.
  2. New experimental plans:
    Mixtures, D-optimal designs and combination of those. Analysis with PLS or Response Surface.
  3. Live 3D rotation of scatter plots:
    Get a visual understanding of the structure of your data through real-time 3D rotation. Applies to 3D-scatter plots, matrix plots and response surface plots.
  4. More professional presentation of your results:
    To ease your documentation work, new gray-tone schemes and features were added to separate information also on black & white printouts.
  5. Add your own transformation routines:
    The Unscrambler® can now utilize transformation DLLs so you can use your favorite pre-processing methods that you develop yourself or get from algorithm libraries. At prediction and classification of new data, The Unscrambler applies all pre-processing stored with the model.
  6. Easier to detect outliers:
    Hotelling T2 statistics allow outlier boundaries to be visualized as ellipses in your score plots, and make the interpretation very simple.
  7. Import of Excel 97 files:
    Import of Excel 97 files with named ranges and embedded charts now fully supported.
  8. Recalculation is now possible after all analyses:
    Recalculation now also works for Analysis of Effects and Response Surface.
  9. Print plots from several windows simultaneously:
    A new print dialog for viewer documents makes it possible to print all visible plots on screen (2 or 4) on the same sheet of paper.
  10. Level markers in contour plots:
    In contour plots, level markers on contour lines are now implemented.
  11. New added matrix when exporting:
    Extended export model to ASCII-MOD format. If exporting full PCA or full Regression model, the matrix "Tai" is included on the output ASCII-MOD file as the last model matrix, but before any MSC model matrix.

[ BACK | TOP ]
 
FAQ Shortcut Keys in The Unscrambler 9.1
See a list of all the shortcut keys in The Unscrambler 9.1. Click Here

[ BACK | TOP ]

 
DATA TABLES (Editor)
 
FAQ What is the size limit of  Unscrambler data tables?
  There is no theoretical limit for the size of data tables in The Unscrambler.
When modeling, limitations may occur with your machine?s capacity to run multivariate models on very large data sets.

[ BACK | TOP ]

 
MODELLING
   
FAQ How to Validate a Model in The Unscrambler® ?
  In The Unscrambler®, validation is always automatically included in model computation. However, what matters most is the choice of a relevant validation method for your case, and the configuration of its parameters.

The general validation procedure for PCA and Regression is as follows:
  • Build a first model with leverage correction or segmented cross validation - the computations will go faster. Allow for a large number of PCs. Cross validation is recommended if you wish to apply Martens Uncertainty Test.
  • Diagnose the first model with respect to outliers, non linearities, any other abnormal behavior. Take advantage of the variety of diagnostic tools available in The Unscrambler®: variance curves, automatic warnings, scores and loadings, stability plots, influence plot, X-Y relation outliers plot, etc.
  • Investigate and fix problems (correct errors, apply transformations etc.)
  • Check improvements by building new model.
  • For regression only: validate intermediate model with a full cross validation, using Uncertainty Testing, then do variable selection based on significant regression coefficients.
  • Validate final model with a proper method (test set or full cross validation).
  • Interpret final model (sample properties, variable relationships, etc.). Check RMSEP for regression models.


[ BACK | TOP ]


 FAQ How to Run a Prediction in The Unscrambler® ?
  In practice, prediction requires three operations:
  1. Build and validate a regression model, using PCR or PLS (see Chapter Multivariate Regression in Practice); save the final version of your model.
  2. Collect X-values for new samples;
  3. Run a prediction, using the chosen regression model.

When your data table is displayed in the Editor, you may access the Task menu to run a Prediction.

[ BACK | TOP ]

FAQ Why do I get different results when I run the same set of data in The Unscrambler and another software?
  The differences encountered when running the same model type on the same set of data in The Unscrambler and other software are generally due to different variable scalings.

In The Unscrambler, the PCA and Regression dialogs show a "Weights" button in the X-variables and Y-variables sheets. By default, the weights are set to 1.0 (that is to say: no weighting), and if left such the model will be built on the covariance matrix. Note that this should only be done if the variables were all measured in the same unit and scale.

If you adjust the weights to "1/SDev" the variables will be standardized, and the model will be built on the correlation matrix.
Also note that in The Unscrambler, the data are centered by default, this unless the "Center Data" option was un-checked. Some software packages require a centering operation before running the model.

[ BACK | TOP ]

 FAQ I made a PLS regression model but I can?t find it when trying to use it for prediction on new samples!
  In the Prediction dialog, always start by specifying the relevant sample set, X-variable set and Y-variable set for your prediction. When clicking on the Find? button, only available regression models that correspond to these settings will show (i.e. regression models that have a matching number of X-variables, and a matching number of Y-variables if you ticked the ?Include Y-reference? box).

Also note:
  1. It is the number of X-variables of the X-variable set field that counts, independently of eventual removed variables in the Keep Out of Calculation field.
  2. Remember that interaction and/or square terms are also terms belonging to the X-variable set

[ BACK | TOP ]

FAQ Can I run predictions from an MLR model in The Unscrambler?
  The Unscrambler?s menu Task-Predict does not offer to run predictions from an MLR model. However, a PLS-R model including the maximum number of components is equivalent to the MLR solution. Therefore you may proceed as follows:
  1. Build a PLS-R model with maximum number of PCs
  2. Use Task-Predict and select your PLS-R model. Make sure to set the number of Components to its maximum, independently of the suggested number of PCs.

    Note that in many cases, a PLS-R model with appropriate number of PCs will give better predictions than an MLR solution. Study your models before you decide to predict from the MLR solution!
     

[ BACK | TOP ]

INTERACTION WITH OTHER SOFTWARE
   
FAQ  What are the different external files formats compatible for import and export to / from The Unscrambler?
  Formats compatible for Import / Export
 
File Format Import Import 3-D Export
ASCII Yes Yes Data
ASCII-MOD - - Model
LOTUS Yes - -
EXCEL Yes Yes -
JCAMP-DX Yes Yes Data
Vision - - Model
Tracker Yes - Model
NSAS Yes - Model
APC Yes - -
GRAMS Yes - -
Matlab Yes Yes Data
MVACDF Yes - Data
 
More details about Instrument compatibility are given in the Technical References chapter, which is available as a .PDF file from CAMO?s web site www.camo.com/TheUnscrambler/Appendices .

[ BACK | TOP ]

FAQ How to Transfer Unscrambler plots to Another Application?
  You can use copy and paste to transfer a plot from The Unscrambler® Viewer to another program. Click on the plot you want to transfer and select Edit - Copy, or select Edit - Copy All if you want to copy all plots together. Then go to the other application and select Edit - Paste.

The plot can be transferred either as a bitmap or as a meta-file (picture). The latter option gives the best quality, but may result in very large files in Word, especially if the plot has many objects (many samples and/or variables, using symbols layout, etc.). You select the appropriate option in the Viewer sheet of the File - System Setup dialog.

Another possibility is to save the plot using File - Save Plot (or right-click on the plot and select Save Plot). This allows you to choose among a few different file formats, which later on can be opened in the application of your choice.

A Special Case: Transferring Table Plots
Table plots (e.g. ANOVA table) are nothing but characters and numbers displayed in a graphical interface. Thus, if you copy a table plot and paste it into another application, you will get the following results:
  1. In a spreadsheet, e.g. Excel: A table, with row and column names;
  2. In a word processor, e.g. Word: A tabulated series of words and values, which can easily be converted into a table (see section Transferring Your Data to a Word Processor).

[ BACK | TOP ]

FAQ When I paste Unscrambler data into Excel, my sample and variable names disappear. How do I export them ?
  In order to get sample and variable names from an Unscrambler data table into Excel, copy your table in The Unscrambler, then use menu Edit-Paste Special in Excel and select to paste as ?Text?.

Note! Depending on your settings, the data itself may not be pasted properly when using the Text option (decimal separator not properly recognized). In this case, place your cursor on the first Data cell in Excel (top left) and use Edit-Paste; this will paste the data as numbers and ensure that decimal separators are recognized properly.

[ BACK | TOP ]

FAQ Can I edit Unscrambler plots after pasting them into an MS Office application ?
  In The Unscrambler, use menu File-System Setup, and in the Viewer sheet choose option Picture format instead of Bitmap. Picture format will let you Edit the picture after Copying-Pasting into MS Office applications.

[ BACK | TOP ]

FAQ I've run the same set of data in The Unscrambler® (PCA) and in another software. The results on variable loadings and sample scores were very different. Why?
  The differences encountered are very often due to different variable scaling. In The Unscrambler®, the PCA and Regression dialogs show a "Weights" button in the X-variables and Y-variables sheets. By default, the weights are set to 1.0 (that is to say: no weighting), and if left such the model will be built on the covariance matrix. Note that this should only be done if the variables were all measured in the same unit and scale.

If you adjust the weights to "1/SDev" the variables will be standardized, and the model will be built on the correlation matrix.
Also note that in The Unscrambler®, the data are centered by default, this unless the "Center Data" option was un-checked. Some software packages may require a separate centering.

[ BACK | TOP ]


FAQ How to Export a Model in ASCII-MOD Format ?
  All results necessary to define a model can be written in the ASCII-MOD format, allowing another program to read in everything necessary to reproduce the model you have made in The Unscrambler. You can also export the model to NSAS or Vision format, etc. This option allows you to export an Unscrambler model to another program, using the ASCII-MOD file format.

Go to File - Export Model and select the kind of result file you want to export. Type in the name of the file you want to export in the Export? dialog, or click the Browse button to get a list of all available models.

The ASCII-MOD file structure is described in the Technical References chapter, which is available as a .PDF file from CAMO?s web site www.camo.com/TheUnscrambler/Appendices .

[ BACK | TOP ]

FAQ How to Export Model to Tracker?
  Tracker models are written in a format used by Foss? instruments. You can write models in both .CAL and .PIF format.

Specify the folder in which you want to save the model in the Folder field in the Export Tracker Model dialog. Use the Browse button if you do not remember the folder name. Then, in the Model name field, enter the name you want the model file to have on the disk.

In the PCs field, enter the number of PCs you want the model to be made up of in the exported model file. This will usually be the optimal number of components you have found during your work in The Unscrambler®.

There are two types of Tracker models; CAL and PIF.

[ BACK | TOP ]

ALGORITHMS AND RESULT MATRICES
   
FAQ Where do I find details on The Unscrambler?s algorithms ?
  Details about Instrument compatibility are given in the Methods References chapter, which is available as a .PDF file from CAMO?s web site www.camo.com/TheUnscrambler/Appendices .

[ BACK | TOP ]

FAQ How can I access the result matrices for my Unscrambler models ?
  Many result matrices are saved on file in Unscrambler models. A number of these are utilized in the pre-defined plots in the Viewer; additional ones are only saved. To access any result matrix, use File-Import-Unscrambler Results. A detailed description of this dialog is accessible in the Unscrambler help system.

The list of available matrices is given in the Technical References chapter, which is available as a .PDF file from CAMO?s web site www.camo.com/TheUnscrambler/Appendices .

[ BACK | TOP ]